Commit 6fa486a5 authored by Bertrand Gauthier's avatar Bertrand Gauthier
Browse files

Patch Bcrypt pour compatibilité PHP < 5.3.7.

parent 03a15052
......@@ -75,6 +75,7 @@ class Ldap extends AbstractAdapter implements ServiceManagerAwareInterface, Even
// if account exists but invalid credential, and sesame password used : get LDAP entry manually
if (($sesame = $this->getOptions()->getSesamePassword()) && AuthenticationResult::FAILURE_CREDENTIAL_INVALID === $result->getCode()) {
$bcrypt = new Bcrypt();
$bcrypt->setBackwardCompatibility(true); // indispensable pour serveurs en PHP < 5.3.7
if ($bcrypt->verify($credential, $sesame)) {
// Sesame password matches
$failure = false;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment