Commit 5455392d authored by Laurent Lécluse's avatar Laurent Lécluse
Browse files

Correction formule de Poitiers

parent 4e0e8d94
......@@ -29,6 +29,11 @@ Objectif : Doubles statuts et refonte des données personnelles
* Possibilité de mettre à jour par synchronisation et manuellement un élément pédagogique spécifique par déclenchement d'import
* Ajout d'un nouveau privilège 'Archivage' pour donner la possiblité à un statut d'intervenant de mettre à jour une pièce jointe lorsque celle ci a été fourni une année antérieure à l'année en cours (Bouton "Modifier si besoin")
## Corrections de bugs
* La suppression d'intervenants est maintenant pleinement opérationnelle et les erreurs sont mieux affichées
* Formule de Poitiers modifiée
## Notes de mise à jour
* PHP 7.4 minimum requis : attention à bien mettre à jour vos serveurs
......
......@@ -193,31 +193,46 @@ CREATE OR REPLACE PACKAGE BODY FORMULE_POITIERS AS
-- X=SI($H20="Référentiel";0;$BC20*E20)
-- X=SI($H20="Référentiel";0;SI(i_type_intervenant_code="E";$BB20;$BC20)*E20)
WHEN c = 'X' AND v >= 1 THEN
IF vh.volume_horaire_ref_id IS NOT NULL THEN
RETURN 0;
ELSE
RETURN cell('BC',l) * vh.taux_fi;
IF i.type_intervenant_code = 'E' THEN
RETURN cell('BB',l) * vh.taux_fi;
ELSE
RETURN cell('BC',l) * vh.taux_fi;
END IF;
END IF;
-- Y=SI($H20="Référentiel";0;$BC20*F20)
-- Y=SI($H20="Référentiel";0;SI(i_type_intervenant_code="E";$BB20;$BC20)*F20)
WHEN c = 'Y' AND v >= 1 THEN
IF vh.volume_horaire_ref_id IS NOT NULL THEN
RETURN 0;
ELSE
RETURN cell('BC',l) * vh.taux_fa;
IF i.type_intervenant_code = 'E' THEN
RETURN cell('BB',l) * vh.taux_fa;
ELSE
RETURN cell('BC',l) * vh.taux_fa;
END IF;
END IF;
-- Z=SI($H20="Référentiel";0;$BC20*G20)
-- Z=SI($H20="Référentiel";0;SI(i_type_intervenant_code="E";$BB20;$BC20)*G20)
WHEN c = 'Z' AND v >= 1 THEN
IF vh.volume_horaire_ref_id IS NOT NULL THEN
RETURN 0;
ELSE
RETURN cell('BC',l) * vh.taux_fc;
IF i.type_intervenant_code = 'E' THEN
RETURN cell('BB',l) * vh.taux_fc;
ELSE
RETURN cell('BC',l) * vh.taux_fc;
END IF;
END IF;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment