metadata.json 1.6 KB
Newer Older
1 2
{
  "name": "camptocamp-postfix",
Raphaël Pinson's avatar
Raphaël Pinson committed
3
  "version": "1.11.0",
Raphaël Pinson's avatar
Raphaël Pinson committed
4
  "author": "camptocamp",
5
  "summary": "Camptocamp Postfix Module",
6
  "license": "Apache-2.0",
7 8 9 10 11 12
  "source": "https://github.com/camptocamp/puppet-postfix",
  "project_page": "https://github.com/camptocamp/puppet-postfix",
  "issues_url": "https://github.com/camptocamp/puppet-postfix/issues",
  "dependencies": [
    {
      "name": "puppetlabs/stdlib",
13
      "version_requirement": ">=4.13.0 <7.0.0"
Raphaël Pinson's avatar
Raphaël Pinson committed
14 15
    },
    {
Mickaël Canévet's avatar
Mickaël Canévet committed
16 17
      "name": "camptocamp/augeas",
      "version_requirement": ">=1.0.0 <2.0.0"
18 19 20
    },
    {
      "name": "puppet/alternatives",
21
      "version_requirement": ">=2.0.0 <4.0.0"
Raphaël Pinson's avatar
Raphaël Pinson committed
22 23 24 25
    },
    {
      "name": "puppetlabs/mailalias_core",
      "version_requirement": ">=1.0.5 <2.0.0"
26 27 28 29 30 31
    }
  ],
  "operatingsystem_support": [
    {
      "operatingsystem": "Debian",
      "operatingsystemrelease": [
Mickaël Canévet's avatar
Mickaël Canévet committed
32
        "7",
33 34
        "8",
        "9"
35 36 37 38 39
      ]
    },
    {
      "operatingsystem": "Ubuntu",
      "operatingsystemrelease": [
Raphaël Pinson's avatar
Raphaël Pinson committed
40
        "14.04",
41 42
        "16.04",
        "18.04"
43 44 45 46 47
      ]
    },
    {
      "operatingsystem": "RedHat",
      "operatingsystemrelease": [
48
        "6",
zeromind's avatar
zeromind committed
49 50
        "7",
        "8"
51
      ]
52 53 54
    },
    {
      "operatingsystem": "Alpine"
55 56 57 58 59 60 61 62
    },
    {
      "operatingsystem": "Fedora",
      "operatingsystemrelease": [
        "28",
        "29",
        "30"
      ]
63
    }
Raphaël Pinson's avatar
Raphaël Pinson committed
64 65 66 67 68 69 70 71 72 73 74
  ],
  "requirements": [
    {
      "name": "puppet",
      "version_requirement": ">= 4.0.0 < 7.0.0"
    }
  ],
  "description": "Postfix Module for Puppet",
  "pdk-version": "1.15.0",
  "template-url": "pdk-default#1.15.0",
  "template-ref": "tags/1.15.0-0-g0bc522e"
75
}