Gemfile 2.24 KB
Newer Older
1
source ENV['GEM_SOURCE'] || "https://rubygems.org"
Raphaël Pinson's avatar
Raphaël Pinson committed
2

3
group :development, :unit_tests do
Raphaël Pinson's avatar
Raphaël Pinson committed
4
5
  gem 'rake',                                              :require => false
  gem 'rspec',                                             :require => false
Mickaël Canévet's avatar
Mickaël Canévet committed
6
  gem 'rspec-puppet',                                      :require => false
7
  gem 'puppetlabs_spec_helper',                            :require => false
8
  gem 'metadata-json-lint',                                :require => false
Mickaël Canévet's avatar
Mickaël Canévet committed
9
  gem 'puppet-lint',                                       :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
10
11
12
  gem 'puppet-lint-unquoted_string-check',                 :require => false
  gem 'puppet-lint-empty_string-check',                    :require => false
  gem 'puppet-lint-spaceship_operator_without_tag-check',  :require => false
13
  gem 'puppet-lint-absolute_classname-check',              :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
14
  gem 'puppet-lint-undef_in_function-check',               :require => false
15
  gem 'puppet-lint-leading_zero-check',                    :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
16
17
  gem 'puppet-lint-trailing_comma-check',                  :require => false
  gem 'puppet-lint-file_ensure-check',                     :require => false
18
  gem 'puppet-lint-version_comparison-check',              :require => false
19
  gem 'puppet-lint-file_source_rights-check',              :require => false
20
  gem 'puppet-lint-alias-check',                           :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
21
  gem 'rspec-puppet-facts',                                :require => false
Mickaël Canévet's avatar
Mickaël Canévet committed
22
  gem 'ruby-augeas',                                       :require => false
Mickaël Canévet's avatar
Mickaël Canévet committed
23
  gem 'puppet-blacksmith',                                 :require => false if RUBY_VERSION !~ /^1\./
Raphaël Pinson's avatar
Raphaël Pinson committed
24
  gem 'json_pure', '< 2.0.2',                              :require => false
25
26
27
end

group :system_tests do
Raphaël Pinson's avatar
Raphaël Pinson committed
28
  gem 'beaker', '~>3.13',     :require => false
29
30
31
32
  gem 'beaker-rspec', '> 5',  :require => false
  gem 'beaker_spec_helper',   :require => false
  gem 'serverspec',           :require => false
  gem 'specinfra',            :require => false
33
34
35
36
37
38
39
40
41
42
end

if facterversion = ENV['FACTER_GEM_VERSION']
  gem 'facter', facterversion, :require => false
else
  gem 'facter', :require => false
end

if puppetversion = ENV['PUPPET_GEM_VERSION']
  gem 'puppet', puppetversion, :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
43
else
44
  gem 'puppet', :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
45
46
end

47
# vim:ft=ruby