Gemfile 1.72 KB
Newer Older
1
source ENV['GEM_SOURCE'] || "https://rubygems.org"
Raphaël Pinson's avatar
Raphaël Pinson committed
2

3
group :development, :unit_tests do
Raphaël Pinson's avatar
Raphaël Pinson committed
4
  gem 'rake',                                              :require => false
Mickaël Canévet's avatar
Mickaël Canévet committed
5
  gem 'rspec-puppet', '~> 2.0',                            :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
6
  gem 'puppetlabs_spec_helper',                            :require => false
Mickaël Canévet's avatar
Mickaël Canévet committed
7
  gem 'puppet-lint',                                       :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
8
9
10
11
  gem 'puppet-lint-unquoted_string-check',                 :require => false
  gem 'puppet-lint-empty_string-check',                    :require => false
  gem 'puppet-lint-spaceship_operator_without_tag-check',  :require => false
  gem 'puppet-lint-variable_contains_upcase',              :require => false
12
  gem 'puppet-lint-absolute_classname-check',              :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
13
  gem 'puppet-lint-undef_in_function-check',               :require => false
14
  gem 'puppet-lint-leading_zero-check',                    :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
15
16
17
18
  gem 'simplecov',                                         :require => false
  gem 'rspec-puppet-facts',                                :require => false
  gem 'json',                                              :require => false
  gem 'metadata-json-lint',                                :require => false
19
20
21
end

group :system_tests do
Raphaël Pinson's avatar
Raphaël Pinson committed
22
  gem 'beaker',        :require => false, :git => 'https://github.com/mcanevet/beaker', :branch => 'openstack'
23
24
  gem 'beaker-rspec',  :require => false
  gem 'serverspec',    :require => false
25
26
27
28
29
30
31
32
33
34
end

if facterversion = ENV['FACTER_GEM_VERSION']
  gem 'facter', facterversion, :require => false
else
  gem 'facter', :require => false
end

if puppetversion = ENV['PUPPET_GEM_VERSION']
  gem 'puppet', puppetversion, :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
35
else
36
  gem 'puppet', :require => false
Raphaël Pinson's avatar
Raphaël Pinson committed
37
38
end

39
# vim:ft=ruby