Commit 1b7f41fa authored by Mickaël Canévet's avatar Mickaël Canévet
Browse files

Update with modulesync_configs [skip ci]

parent fc0de99e
--- ---
language: ruby language: ruby
bundler_args: --without development bundler_args: --without system_tests
script: ["bundle exec rake validate", "bundle exec rake lint", "bundle exec fakeroot rake spec SPEC_OPTS='--format documentation'", "bundle exec rake metadata"] script: ["bundle exec rake validate", "bundle exec rake lint", "bundle exec fakeroot rake spec SPEC_OPTS='--format documentation'", "bundle exec rake metadata"]
matrix: matrix:
fast_finish: true fast_finish: true
include: include:
- rvm: 1.8.7 - rvm: 1.8.7
env: PUPPET_GEM_VERSION="~> 3.0" env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
- rvm: 1.8.7
env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
- rvm: 1.9.3 - rvm: 1.9.3
env: PUPPET_GEM_VERSION="~> 3.0" env: PUPPET_GEM_VERSION="~> 3.0"
- rvm: 2.0.0 - rvm: 2.0.0
......
source ENV['GEM_SOURCE'] || "https://rubygems.org" source ENV['GEM_SOURCE'] || "https://rubygems.org"
group :development, :test do group :development, :unit_tests do
gem 'rake', :require => false gem 'rake', :require => false
gem 'rspec-puppet', :require => false, :git => 'https://github.com/camptocamp/rspec-puppet.git', :branch => 'future-no-import' gem 'rspec-puppet', :require => false, :git => 'https://github.com/rodjek/rspec-puppet.git'
gem 'puppetlabs_spec_helper', :require => false gem 'puppetlabs_spec_helper', :require => false
gem 'puppet-lint', :require => false gem 'puppet-lint', :require => false
gem 'metadata-json-lint', :require => false gem 'simplecov', :require => false
gem 'puppet_facts', :require => false, :git => 'https://github.com/camptocamp/puppet_facts.git' gem 'puppet_facts', :require => false, :git => 'https://github.com/camptocamp/puppet_facts.git'
gem 'json', :require => false
gem 'metadata-json-lint', :require => false
end
group :system_tests do
gem 'beaker-rspec', :require => false
gem 'serverspec', :require => false
end end
if facterversion = ENV['FACTER_GEM_VERSION'] if facterversion = ENV['FACTER_GEM_VERSION']
......
...@@ -2,6 +2,7 @@ require 'puppetlabs_spec_helper/rake_tasks' ...@@ -2,6 +2,7 @@ require 'puppetlabs_spec_helper/rake_tasks'
require 'puppet-lint/tasks/puppet-lint' require 'puppet-lint/tasks/puppet-lint'
PuppetLint.configuration.fail_on_warnings PuppetLint.configuration.fail_on_warnings
PuppetLint.configuration.send('relative')
PuppetLint.configuration.send('disable_80chars') PuppetLint.configuration.send('disable_80chars')
PuppetLint.configuration.ignore_paths = ["spec/**/*.pp", "pkg/**/*.pp"] PuppetLint.configuration.ignore_paths = ["spec/**/*.pp", "pkg/**/*.pp"]
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment