Commit 5f98c350 authored by Raphaël Pinson's avatar Raphaël Pinson
Browse files

Use parser=future

parent 289d61e9
...@@ -11,6 +11,11 @@ matrix: ...@@ -11,6 +11,11 @@ matrix:
env: PUPPET_GEM_VERSION="~> 3.0" env: PUPPET_GEM_VERSION="~> 3.0"
- rvm: 2.0.0 - rvm: 2.0.0
env: PUPPET_GEM_VERSION="~> 3.0" env: PUPPET_GEM_VERSION="~> 3.0"
- rvm: 2.0.0
env: PUPPET_GEM_VERSION="~> 3.0" PUPPET_PARSER="future"
allow_failures:
- rvm: 2.0.0
env: PUPPET_GEM_VERSION="~> 3.0" PUPPET_PARSER="future"
notifications: notifications:
email: false email: false
deploy: deploy:
......
...@@ -2,7 +2,7 @@ source ENV['GEM_SOURCE'] || "https://rubygems.org" ...@@ -2,7 +2,7 @@ source ENV['GEM_SOURCE'] || "https://rubygems.org"
group :development, :test do group :development, :test do
gem 'rake', :require => false gem 'rake', :require => false
gem 'rspec-puppet', :require => false gem 'rspec-puppet', :require => false, :git => 'https://github.com/rodjek/rspec-puppet.git'
gem 'puppetlabs_spec_helper', :require => false gem 'puppetlabs_spec_helper', :require => false
gem 'puppet-lint', :require => false gem 'puppet-lint', :require => false
gem 'metadata-json-lint', :require => false gem 'metadata-json-lint', :require => false
......
...@@ -17,6 +17,10 @@ RSpec.configure do |c| ...@@ -17,6 +17,10 @@ RSpec.configure do |c|
if Gem::Version.new(`puppet --version`) >= Gem::Version.new('3.5') if Gem::Version.new(`puppet --version`) >= Gem::Version.new('3.5')
Puppet.settings[:strict_variables]=true Puppet.settings[:strict_variables]=true
end end
if ENV['PUPPET_PARSER'] == 'future'
Puppet.settings[:parser]='future'
end
end end
c.after :each do c.after :each do
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment