Commit ba838472 authored by Bob Vincent's avatar Bob Vincent Committed by Raphaël Pinson

Require and use the puppet-alternatives module.

parent ad99414a
......@@ -12,10 +12,9 @@ class postfix::service {
restart => $::postfix::params::restart_cmd,
}
if $::osfamily == 'RedHat' {
exec { 'alternatives --set mta /usr/sbin/sendmail.postfix':
alternatives { 'mta':
path => '/usr/sbin/sendmail.postfix',
require => Service['postfix'],
path => '/bin:/sbin:/usr/bin:/usr/sbin',
unless => 'test /etc/alternatives/mta -ef /usr/sbin/sendmail.postfix',
}
}
}
......@@ -19,6 +19,10 @@
{
"name": "camptocamp/augeas",
"version_requirement": ">=1.0.0 <2.0.0"
},
{
"name": "puppet/alternatives",
"version_requirement": ">=2.0.0 <3.0.0"
}
],
"operatingsystem_support": [
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment