This project is mirrored from https://github.com/camptocamp/puppet-postfix.git. Pull mirroring updated .
  1. 17 Aug, 2018 1 commit
  2. 24 May, 2018 2 commits
    • Romain Tartière's avatar
      Relax permissions · 44ab771c
      Romain Tartière authored
      These files do not contain sensitive data, so keep the default files
      permissions.
      44ab771c
    • Romain Tartière's avatar
      Unbreak sendmail(1) · ee220c86
      Romain Tartière authored
      sendmail(1) reads parts of it's configuration from the main.cf file.
      When the file is not readable, the command invocation will fail with the
      following error:
      
      fatal: open /etc/postfix/main.cf: Permission denied
      
      The parameters read from main.cf are documented here:
      http://www.postfix.org/sendmail.1.html
      ee220c86
  3. 09 May, 2018 1 commit
  4. 16 Jan, 2018 11 commits
  5. 20 Sep, 2017 2 commits
  6. 19 Sep, 2017 1 commit
    • Raphaël Pinson's avatar
      Fix resource dependencies (#185) · 17d9d6ee
      Raphaël Pinson authored
      * Fix resource dependencies
      
      Dependencies must be set only if the resources exist in the catalog.
      For some weird reason, this worked in Puppet 4 (and shouldn't have).
      
      * Fix AbsolutePath test for Puppet 5
      17d9d6ee
  7. 18 Sep, 2017 1 commit
  8. 25 Aug, 2017 1 commit
  9. 09 Aug, 2017 3 commits
  10. 22 May, 2017 1 commit
  11. 17 May, 2017 1 commit
    • Raphaël Pinson's avatar
      Data types (#169) · 788d8764
      Raphaël Pinson authored
      * Use data types
      
      * Use data types
      
      * Use data types
      
      * Use data types
      
      * Use data types
      
      * Use data types
      
      * Use data types
      788d8764
  12. 18 Apr, 2017 1 commit
  13. 31 Mar, 2017 1 commit
  14. 10 Jan, 2017 3 commits
  15. 05 Jan, 2017 1 commit
  16. 18 Nov, 2016 1 commit
    • Garrett Honeycutt's avatar
      Ruby231 (#155) · 3b987762
      Garrett Honeycutt authored
      * Include puppet version requirements in metadata
      
      * Support Ruby 2.3.1
      
      This patch is needed to support the new Puppet v4 AIO which uses Ruby
      2.3.1.
      3b987762
  17. 17 Nov, 2016 1 commit
  18. 08 Nov, 2016 4 commits
  19. 03 Nov, 2016 1 commit
    • Christian Kaenzig's avatar
      Fix map calling in hash · 799641de
      Christian Kaenzig authored
      map defines the default path by prepending '/etc/postfix/' to $name, so
      this doesn't work when the name is already the absolute path. We need
      to force the path passed to map.
      799641de
  20. 23 Sep, 2016 1 commit
  21. 24 Aug, 2016 1 commit
    • Angel L. Mateo's avatar
      Add a map define to create postfix maps (#138) · 755d8684
      Angel L. Mateo authored
      * Add a map define to create postfix maps
      
      It is similar to existing hash define, but this define can create maps
      of any type, not just hash.
      
      * Refactor postfix::hash to avoid duplicate code
      
      postfix::hash uses now the new postfix::map to create the hash
      755d8684