Commit 60776231 authored by Nathan Ward's avatar Nathan Ward
Browse files

Add function to check if the installed freeradius version, or the one we are...

Add function to check if the installed freeradius version, or the one we are targetting is 3.1.x or not
parent 9ead3da8
...@@ -28,6 +28,16 @@ class freeradius ( ...@@ -28,6 +28,16 @@ class freeradius (
notify { 'This module is only compatible with FreeRADIUS 3.': } notify { 'This module is only compatible with FreeRADIUS 3.': }
} }
# Guess if we are running FreeRADIUS 3.1.x
if (
($package_ensure =~ /^3\.1\./) or
($facts['freeradius_version'] and $facts['freeradius_version'] =~ /^3\.1\./)
) {
$fr_3_1 = true
} else {
$fr_3_1 = false
}
validate_re($log_destination, '^(files|syslog|stdout|stderr)$', validate_re($log_destination, '^(files|syslog|stdout|stderr)$',
"log_destination value (${log_destination}) is not a valid value") "log_destination value (${log_destination}) is not a valid value")
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment