Skip to content
  • Francesc Guasch's avatar
    New development features (#1191) · d6c91852
    Francesc Guasch authored
    * feature(iso): new russian distro Linux Astra
    
    issue #1096
    
    * Fix #1104 mariadb (#1105)
    
    * fix(install): create some tables forcing utf8
    
    fixes issue #1104
    
    * feature(frontend): disable timeout check in login form (#1110)
    
    fixes issue #1102
    
    * feature(backend):Set three first MAC octets as static (#1111)
    
    issue #1103
    
    issue #1102
    
    * 1098 access (#1113)
    
    * fix(access): Add access tab
    * fix(access): Improve appearance
    * fix(access): Add i18n strings
    
    Issue #1098
    
    * fix(frontend): login with spaces now fails (#1106)
    
    issue #1100
    
    * Fix/1119 timeout (#1120)
    
    * wip(frontend): pass configured timeout when starting
    
    issue #1119
    
    * Feature #1115 pools (#1121)
    
    * feature(frontend): manage pools
    
    issue #1115
    
    * wip(frontend): fallback bt4 upgrade (#958)
    
    * feature(frontend): fallback bt4 upgrade
    
    issue #993 and #949
    
    * 949 fallback (#1122)
    
    feature(frontend): fallback bt4 upgrade
    
    issue #993 and #949
    
    * test(request): change curr and max memory
    
    issue #1123
    
    * fix(request): change current memory
    
    issue #1123
    
    * Fix(i18n): Empty lines transifex errors
    
    * wip(test): improved process waiting
    
    * fixed english duplicates
    
    * fixed when no display info available
    
    * wip(frontend): fixed pool form
    
    * fixed tests when there are no testing nodes
    
    * wip(frontend): bootstrap select picker on fallback
    
    issue #993
    
    * remove old Ubuntu ISOs
    
    * fix(backend): refresh ISOs misplaced file
    
    It only happened if the ISO cache was removed
    
    * Feature #993 fallback (#1124)
    
    feature(frontend): get all fallback files for the package
    
    * wip(frontend): fallback for raphael fixed
    * wip(frontend): get original files for fallback
    * Also fix tell user to install agent for remote tests
    * wip(frontend); version badge
    
    issue #993
    
    * show open ports info only if there is any
    
    * Fix #1125 iso (#1126)
    
    fix(backend): test and checks for old ISOs
    
    issue #1125
    
    * refactor volume management (#1128)
    
    refactor(volumes): volume management
    
    issue #1127
    
    * refactor(frontend): removed warning undefined
    
    * refactor(tests); fix check with local ips
    
    in some environments with no network it may fail
    
    * refactor(backend): remove only if necessary
    
    * Fix #1125 iso (#1129)
    
    * fix(backend): test and checks for old ISOs
    * feature(ISO): Arch Linux support
    * wip(download): fixed some regexp downloads
    
    issue #1125
    
    * Fix #1131 pool (#1133)
    
    fix(backend): fixed create clone when pooling
    
    * fix(backend): reviewed pool clones management
    * refactor(frontend): improved user feedback
    * test(backend): pick a machine from pool
    
    issue #1131
    
    * Fix ports expose (#1142)
    
    * test(networking): flush and check FORWARD table
    * fix(networking): open forward chain when exposing ports
    * fix(frontend): allow ports beyond 99
    
    issue #1134
    
    * Fix prepare base (#1144)
    
    * test(backend): check prepare fails
    * fix(backend): prepare base recover when fails
    
    issue #1143
    
    * fixed with ng-cloak (#1139)
    
    issue #1138
    
    * wip(install): download fallback files
    
    * smbios hostname (#1148)
    
    * test(KVM): change smbios on rename
    * fix(KVM): change smbios on rename
    
    fiuxes issue #1146
    
    * Update fa.po (#1149)
    
    Some texts from administration section
    
    * fix(networking): properly deny restricted ports (#1147)
    
    issue #1134
    
    * fix(documentation):Review requirements page (#1156)
    
    updated the requierements page to specify the Windows configuration
    
    fixes #1152
    
    * fix(frontend): Improve users management in admin (#1159)
    
    Only show errors when the field loses focus
    Added a "Show password" button
    "Cancel" button now redirects to the users page (before it redirected to the VMs page)
    
    fixes #1140
    
    * User experience access directly to virtual desktop if only has one machine (#1160)
    
    feat(frontend): direct access if only one machine
    
    Check number of machines
    If user only has one clone, redirect to file.vv and open spice client
    
    Issue #1145
    
    * feat(backend): remove user from cli (#1161)
    
    Was proposed by @rogerferre
    
    Issue #1132
    
    * Test #1137 mojo (#1151)
    
    * wip(frontend): return http status when failed login
    
    issue #1137 and it will affect issue #1141 too
    
    * test: allow test to connect to the MySQL DB
    
    issue #1137
    
    * test(frontend): test login and create machine
    
    issue #1137
    
    * wip(test): create base and clone it
    
    issue #1137
    
    * wip(test): show some req messages
    
    * refactor(test): reconnect when timed out
    
    issue #1137
    
    * Feature do not remove CD (#1158)
    
    feature(backend): add option with_cd on create base
    
    * test(volumes): check for CD
    * refactor(tests): do not wait for some reqs
    * test(backend): check ISO files in bases
    * wip(backend): set driver for CD-ROM
    
    issue #1116
    
    * removed debug in test
    
    * wip(frontend): turn LDAP auth object into SQL
    
    this is needed to access auth functions
    
    issue #1154
    
    * fix(networking): properly deny restricted ports (#1181)
    
    issue #1134
    
    * Refactor for ubuntu eoan (#1183)
    
    * test(ldap): add config files for eaon tests
    * fix(test): remove user just logged in to refrsh
    
    issue #1177
    
    * fixed test failed when many bridges
    
    * removed debug
    
    * Fix/1185 update cancel hyperlink (#1186)
    
    fix(frontend): Update cancel hyperlink
    
    fixes #1185  and part of #1140
    
    * Feature/1145 directly (#1176)
    
    feat(frontend): direct access if only one machine
    
    Check number of machines
    If user only has one clone, redirect to file.vv and open spice client
    
    Issue #1145
    
    * fix(frontend): Improve users management in admin (#1184)
    
    refactor(frontend): Improve users management in admin
    
        Change button name to "new user"
        Table hides until the "search" button is clicked
    
    fixes #1140
    
    * fix(frontend): Improve new machine page (#1189)
    
    * Disk, Swap and RAM numeric entry
    * Enable SWAP volumes by default on new machine
    * Minimum disk size entry set by the selected ISO
    
    fixes #1150 & #1154
    
    * Refactor nodes (#1190)
    
    refactor(backend): improved remote nodes response
    
    * feature(CLI): run one request
    * improve zombie management
    * refactor(backend): check status only if requested
    * refactor(backend): cache nodes storage
    * install: add dependency for IO::Scalar
    
    issue #1188
    d6c91852