Commit 23e0b309 authored by david.verdin's avatar david.verdin
Browse files

[bug] The "important_changes.pl" script was not launched. also took into...

[bug] The "important_changes.pl" script was not launched. also took into account the fact that the version was previously stored in Version.pm


git-svn-id: https://subversion.renater.fr/sympa/trunk@5900 05aa8bb8-cd2b-0410-b1d7-8918dfa770ce
parent 842f21a3
......@@ -90,12 +90,14 @@ nextstep:
@echo "#######################################################"
importantchanges:
if [ -f $(DESTDIR)$(modulesdir)/Version.pm ]; then \
previous=`perl -Mlib=$(DESTDIR)$(modulesdir) -MVersion -e 'print $$Version::Version'`; \
if [ -f $(DESTDIR)$(modulesdir)/Constants.pm ]; then \
previous=`perl -Mlib=$(DESTDIR)$(modulesdir) -MVersion -e 'print Sympa::Constants::VERSION'`; \
elif [ -f $(DESTDIR)$(bindir)/Version.pm ]; then \
previous=`perl -Mlib=$(DESTDIR)$(bindir) -MVersion -e 'print $$Version::Version'`; \
fi; \
$(PERL) $(top_srcdir)/important_changes.pl \
--current $(VERSION) \
--previous $${previous}
--previous $${previous};
uninstall-hook:
rm -f $(DESTDIR)$(confdir)/sympa.conf
......
......@@ -44,7 +44,10 @@ my $previous_version = $options{previous};
my $current_version = $options{current};
# exit immediatly if previous version is higher or equal
exit 0 if $previous_version >= $current_version;
if (($previous_version eq $current_version) ||
&higher($previous_version,$current_version)){
exit 0;
}
print <<EOF;
You are upgrading from Sympa $previous_version
......@@ -53,11 +56,6 @@ They might be incompatible changes:
<RETURN>
EOF
if (($previous_version eq $current_version) ||
&higher($previous_version,$current_version)){
exit 0;
}
my $wait = <STDIN>;
## Extracting Important changes from release notes
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment