Commit 3121748c authored by IKEDA Soji's avatar IKEDA Soji
Browse files

Update a dependency MHonArc::UTF8. See also sympa-community/MHonArc#7

parent 2e03ac8c
...@@ -96,7 +96,7 @@ requires 'List::Util::XS', '>= 1.20'; ...@@ -96,7 +96,7 @@ requires 'List::Util::XS', '>= 1.20';
requires 'Locale::Messages', '>= 1.20'; requires 'Locale::Messages', '>= 1.20';
# MHonArc is used to build Sympa web archives # MHonArc is used to build Sympa web archives
requires 'MHonArc::UTF8'; requires 'MHonArc::UTF8', '>= 2.6.23';
# Required to compute digest for password and emails # Required to compute digest for password and emails
requires 'MIME::Base64', '>= 3.03'; requires 'MIME::Base64', '>= 3.03';
......
...@@ -554,20 +554,11 @@ sub check_modules { ...@@ -554,20 +554,11 @@ sub check_modules {
print gettext('was not found on this system.') . "\n"; print gettext('was not found on this system.') . "\n";
install_module($mod, {'default' => $default}, $cpan_modules); install_module($mod, {'default' => $default}, $cpan_modules);
} else { } else {
my ($vs, $v); my ($vs, $v);
$vs = "$mod" . "::VERSION";
## MHonArc module does not provide its version the standard way {
if ($mod =~ /^MHonArc/i) { no strict 'refs';
require "mhamain.pl"; $v = $$vs;
$v = $mhonarc::VERSION;
} else {
$vs = "$mod" . "::VERSION";
{
no strict 'refs';
$v = $$vs;
}
} }
my $rv = $cpan_modules->{$mod}{required_version} || "1.0"; my $rv = $cpan_modules->{$mod}{required_version} || "1.0";
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment