Commit 95a3505d authored by sympa-authors's avatar sympa-authors
Browse files

Added a warning about the long installation process


git-svn-id: https://subversion.renater.fr/sympa/trunk@3198 05aa8bb8-cd2b-0410-b1d7-8918dfa770ce
parent 4bc90eb3
...@@ -164,10 +164,20 @@ main_SRC = AUTHORS COPYING ChangeLog INSTALL KNOWNBUGS NEWS README ...@@ -164,10 +164,20 @@ main_SRC = AUTHORS COPYING ChangeLog INSTALL KNOWNBUGS NEWS README
LOG_SOCKET_TYPE = unix LOG_SOCKET_TYPE = unix
#endif #endif
all: checkperl checkcpan sources man locale all: warning checkperl checkcpan sources man locale
rpm: build_rh_rpm build_mdk_rpm rpm: build_rh_rpm build_mdk_rpm
warning:
@echo "######################## W A R N I N G ######################"; \
echo "## If it is the first time you install Sympa on this server :"; \
echo "## It may take a while...."; \
echo "## The reason is that Sympa requires many Perl modules that"; \
echo "## are not distributed with the standard Perl distribution."; \
echo "## We'll try to install these modules semi-automatically..."; \
echo "#############################################################"; \
read rep;
checkperl: checkperl:
@if [ $(PERL_VERSION) = '5.006' ]; then \ @if [ $(PERL_VERSION) = '5.006' ]; then \
echo "##################################"; \ echo "##################################"; \
......
...@@ -508,10 +508,20 @@ ChangeLog: ...@@ -508,10 +508,20 @@ ChangeLog:
@CVS2CL@ @CVS2CL@
#endif #endif
all: checkperl checkcpan sources man locale all: warning checkperl checkcpan sources man locale
rpm: build_rh_rpm build_mdk_rpm rpm: build_rh_rpm build_mdk_rpm
warning:
@echo "######################## W A R N I N G ######################"; \
echo "## If it is the first time you install Sympa on this server :"; \
echo "## It may take a while...."; \
echo "## The reason is that Sympa requires many Perl modules that"; \
echo "## are not distributed with the standard Perl distribution."; \
echo "## We'll try to install these modules semi-automatically..."; \
echo "#############################################################"; \
read rep;
checkperl: checkperl:
@if [ $(PERL_VERSION) = '5.006' ]; then \ @if [ $(PERL_VERSION) = '5.006' ]; then \
echo "##################################"; \ echo "##################################"; \
...@@ -522,6 +532,7 @@ checkperl: ...@@ -522,6 +532,7 @@ checkperl:
echo "## If your Perl version is 5.6.0 AND if your system is Solaris :"; \ echo "## If your Perl version is 5.6.0 AND if your system is Solaris :"; \
echo "## See also http://bugs.perl.org/perlbug.cgi?req=bidmids&bidmids=20000522.003"; \ echo "## See also http://bugs.perl.org/perlbug.cgi?req=bidmids&bidmids=20000522.003"; \
echo "#############################################################################"; \ echo "#############################################################################"; \
read rep; \
fi fi
@if [ ! -f $(SUIDPERL) ]; then \ @if [ ! -f $(SUIDPERL) ]; then \
echo "##################################"; \ echo "##################################"; \
...@@ -535,6 +546,7 @@ checkperl: ...@@ -535,6 +546,7 @@ checkperl:
echo "## You don't have msgfmt installed. It is required to build message catalogues"; \ echo "## You don't have msgfmt installed. It is required to build message catalogues"; \
echo "## msgfmt is provided with a 'gettest' package on most systems..."; \ echo "## msgfmt is provided with a 'gettest' package on most systems..."; \
echo "#####################################################"; \ echo "#####################################################"; \
read rep; \
fi fi
sources: src/Makefile src/queue.c src/bouncequeue.c src/aliaswrapper.c sources: src/Makefile src/queue.c src/bouncequeue.c src/aliaswrapper.c
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment