Commit 1df6a3d7 authored by Laurent Lécluse's avatar Laurent Lécluse
Browse files

Correction bug formule Poitiers + changelog & tests d'ancres internes pour les versions stables

parent 6b4a398c
# Versions stables
[OSE 15.3](#OSE 15.3)
[OSE 14.20](#OSE 14.20)
# OSE 16 (à venir)
Objectif : Connecteur Export OSE => Logiciel RH + import Actul+
# OSE 15.3 (09/06/2021)
## Correction de bug
* Formule de poitiers modifiée (pb de division par zéro relatif au plafond réf. corrigé) (#37741)
# OSE 15.2 (08/06/2021)
## Nouveautés
......@@ -149,6 +164,17 @@ Pour alimenter la table employeur de OSE, vous avez deux possiblités :
* soit importer votre propre liste d'employeurs via une vue source [SRC_EMPLOYEUR](doc/Connecteurs-Import/Création-tables/EMPLOYEUR.md) dédiée, à l'instar des autres connecteurs et ainsi alimenter la table employeur en la synchronisant avec votre vue source.
* soit utiliser le référentiel sirene officiel de [data.gouv.fr](https://www.data.gouv.fr/fr/datasets/base-sirene-des-entreprises-et-de-leurs-etablissements-siren-siret/) que nous vous préparons et mettons à disposition avec une mise à jour régulière. Pour cela vous devez utiliser la commande `./bin/ose update-employeur` qui se chargera de remplir la table employeur avec ces données. Cette commande devra être exécutée de manière régulière, une fois par mois environ si vous voulez que votre référentiel d'employeurs soit à jour.
# OSE 14.20 (09/06/2021)
## Correction de bug
* Formule de poitiers modifiée (pb de division par zéro relatif au plafond réf. corrigé) (#37741)
# OSE 14.19 (08/06/2021)
# Nouveautés
......
......@@ -314,8 +314,9 @@ CREATE OR REPLACE PACKAGE BODY FORMULE_POITIERS AS
-- AJ=SI(AI$35<$AJ$9;AI20;SI(AI$35=0;0;AI20/AI$35*$AJ$9))
-- AJ=SI(AI$35<i_param_1;AI20;AI20/AI$35*i_param_1)
-- AJ=SI(OU(i_param_1=0;AI$35<i_param_1);AI20;AI20/AI$35*i_param_1)
WHEN c = 'AJ' AND v >= 1 THEN
IF cell('AI35') < i.param_1 THEN
IF i.param_1 = 0 OR cell('AI35') < i.param_1 THEN
RETURN cell('AI',l);
ELSE
RETURN cell('AI',l) / cell('AI35') * i.param_1;
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment