Commit 3b987762 authored by Garrett Honeycutt's avatar Garrett Honeycutt Committed by Raphaël Pinson
Browse files

Ruby231 (#155)

* Include puppet version requirements in metadata

* Support Ruby 2.3.1

This patch is needed to support the new Puppet v4 AIO which uses Ruby
2.3.1.
parent 15609c11
......@@ -21,6 +21,8 @@ matrix:
env: PUPPET_GEM_VERSION="~> 3.0" FUTURE_PARSER="yes"
- rvm: 2.1.9
env: PUPPET_GEM_VERSION="~> 4.5.0"
- rvm: 2.3.1
env: PUPPET_GEM_VERSION="~> 4"
- rvm: default
sudo: required
dist: trusty
......
......@@ -8,6 +8,9 @@
"project_page": "https://github.com/camptocamp/puppet-postfix",
"issues_url": "https://github.com/camptocamp/puppet-postfix/issues",
"description": "Postfix Module for Puppet",
"requirements": [
{"name":"puppet","version_requirement":">= 3.0.0 < 5.0.0" }
],
"dependencies": [
{
"name": "puppetlabs/stdlib",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment